import re
regex = re.compile(r"(?<!^)(\B|b)(?!$)", flags=re.MULTILINE)
test_str = "Hello"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)