const regex = /^(.+?)(?<Number>\d+)\z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+?)(?<Number>\\d+)\\z', 'gm')
const str = `text12223`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);