$re = '/^(.+?)(?<Number>\d+)\z/m';
$str = 'text12223';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;