import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "to score exactly \\d[ or \\d]? goals[^\\n]*";
final String string = "Subject:\n"
+ " Security ID: S-1-5-21-3368353891-1012177287-890106238-22451\n"
+ " Account Name: ChamaraKer\n"
+ " Account Domain: JIC\n"
+ " Logon ID: 0x1fffb\n\n"
+ "Object:\n"
+ " Object Server: Security\n"
+ " Object Type: File\n"
+ " Object Name: D:\\ApacheTomcat\\apache-tomcat-6.0.36\\logs\\localhost.2013-07-01.log\n"
+ " Handle ID: 0x11dc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}