# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"to score exactly \d[ or \d]? goals[^\n]*"
test_str = ("Subject:\n"
" Security ID: S-1-5-21-3368353891-1012177287-890106238-22451\n"
" Account Name: ChamaraKer\n"
" Account Domain: JIC\n"
" Logon ID: 0x1fffb\n\n"
"Object:\n"
" Object Server: Security\n"
" Object Type: File\n"
" Object Name: D:\\ApacheTomcat\\apache-tomcat-6.0.36\\logs\\localhost.2013-07-01.log\n"
" Handle ID: 0x11dc")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.