re = /(?<range>\d{4}-\d{2}-\d{2}\.\.\d{4}-\d{2}-\d{2})|(?<day>\d{4}-\d{2}-\d{2})|(?<month>\d{4}-\d{2})|(?<quarter>\d{4}-Q\d)|(?<year>\d{4})/m
str = '2021
2022-01
2021-02-28
2022-Q4
2021-02-01..2021-12-31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end