using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^(?:[(]?\b(?:_xTagsx_)\b(?:and|[ ,.&+/-])*)+[:. \)-]*|(?:[:. \(-]|in|with|using)*(?:\b(?:_xTagsx_)\b(?:and|[ ,&+/)-])*)+([?.! ]*)$)";
string substitution = @"$1";
string input = @"Note use of _xTagsx_ placeholder; this is replaced in code.
Be careful: any escaped characters will require double-escape in string to form regexp.
** Flags should be gi in production; 'm' for test here only.
Remove leading tags from:
_xTagsx_ & _xTagsx_: Rest of title
_xTagsx_ - _xTagsx_ - _xTagsx_ - Rest of title
_xTagsx_ Rest of title
_xTagsx_, _xTagsx_ & _xTagsx_ Rest of title
_xTagsx_. Checking if string contains text from an array of substrings.
_xTagsx_ and _xTagsx_:
_xTagsx_ - Rest of title
_xTagsx_/_xTagsx_ - Rest of title
(_xTagsx_) Rest of title
Remove Trailing tags (but leave final punctuation, if any) from:
How to use <= in _xTagsx_ _xTagsx_?
Rest of title (_xTagsx_)
Rest of title (_xTagsx_/_xTagsx_ - _xTagsx_)
Rest of title - in _xTagsx_.
Leave alone:
Use of _xTagsx_ in general.
_xTagsx_as part of a word_xTagsx_";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}