import Foundation
let pattern = #"(?:^(?:[([]?(?:_xTagsx_)(?!\.\w)(?:and|[ ,.&+/-])*)+[:. \)\]-]*|\b(?:(?:[:. \(\[-]|in|with|using|by|for)*(?:(?:_xTagsx_)(?:and|[ ,&+/)\]-])*)*)+([?.! ]*)$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Note use of _xTagsx_ placeholder; this is replaced in code.
Be careful: any escaped characters will require double-escape in string to form regexp.
** Flags should be gi in production; 'm' for test here only.
Remove leading tags from:
_xTagsx_ & _xTagsx_: Rest of title
_xTagsx_ - _xTagsx_ - _xTagsx_ - Rest of title
_xTagsx_ Rest of title
_xTagsx_, _xTagsx_ & _xTagsx_ Rest of title
_xTagsx_. Checking if string contains text from an array of substrings.
_xTagsx_ and _xTagsx_:
_xTagsx_ - Rest of title
_xTagsx_/_xTagsx_ - Rest of title
(_xTagsx_) Rest of title
[_xTagsx_][_xTagsx_] Rest of title
Remove Trailing tags (but leave final punctuation, if any) from:
How to use <= in _xTagsx_ _xTagsx_?
Rest of title (_xTagsx_)
Rest of title [_xTagsx_][_xTagsx_]
Rest of title (_xTagsx_/_xTagsx_ - _xTagsx_)
Rest of title - in _xTagsx_.
Rest of title by _xTagsx_?
Rest of title for _xTagsx_!
Rest of title with _xTagsx_?
Leave alone:
Use of _xTagsx_ in general.
Rest of title Kremlin _xTagsx_.
_xTagsx_.io.InvalidClassException
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)