package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^-{2,}\s*(\w+(?:\s+\w+)*)\s*-{2,}$`)
var str = `-------- Variable used for recipe visualization only - Not loaded into PLC --------`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}