$re = '/(?<=)\{[^\}]*\}(?=)/im';
$str = '"This is the string and it contains {0} a few {1} sets of curly brackets"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);