package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*\/)?1-[^\/]*\.js$`)
var str = `./home/1-ddd.js
./home/2-homed.js `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}