#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)is_granted\((\[(.*?)\])"
Local $sString = "excludeIf = "expr(object.job === null or not is_granted(['VIEW', object.job]))"" & @CRLF & _
"excludeIf = "expr(object.job === null or not is_granted(['VIEW']))"" & @CRLF & _
"" & @CRLF & _
"excludeIf = "expr(not is_granted(['VIEW_TASKS, object.site']) and not is_granted(['SITE_PERMISSION_VIEW_TASKS', object.asset.getSite()]))"," & @CRLF & _
"" & @CRLF & _
"* excludeIf = "expr(not is_granted(['SITE_PERMISSION_NOTIFY_UPDATES']) and not is_granted(['OPERATIVE_PERMISSION_NOTIFY_UPDATES', object.job.getServiceProvider()]))"," & @CRLF & _
"" & @CRLF & _
"$this->type = strtolower(preg_replace('/([a-z])([A-Z])/', '$1_$2', $reflection->getShortName()));"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")