import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\d*[.]?\\d*\\d";
final String string = "\\par }{\\rtlch\\fcs1 \\ab\\af1\\afs20 \\ltrch\\fcs0 \\b\\f1\\fs20\\insrsid13305240\\charrsid3175333 \\hich\\af1\\dbch\\af31505\\loch\\f1 Xray-source / Detector distance:}{\\rtlch\\fcs1 \\ab\\af1\\afs20 \\ltrch\\fcs0 \\b\\f1\\fs20\\uld\\insrsid13305240\\charrsid3175333 \\tab \\tab }{\n"
+ "\\rtlch\\fcs1 \\ab\\af1\\afs20 \\ltrch\\fcs0 \\b\\f1\\fs20\\insrsid13305240\\charrsid3175333 \\hich\\af1\\dbch\\af31505\\loch\\f1 529 mm}{\\rtlch\\fcs1 \\af1\\afs20 \\ltrch\\fcs0 \\f1\\fs20\\insrsid13305240 \\hich\\af1\\dbch\\af31505\\loch\\f1 (20.861 inches)\n"
+ "\\par \\hich\\af1\\dbch\\af31505\\loch\\f1 Rotation axis / Detector \\hich\\af1\\dbch\\af31505\\loch\\f1 distance:}{\\rtlch\\fcs1 \\af1\\afs20 \\ltrch\\fcs0 \\f1\\fs20\\uld\\insrsid13305240 \\hich\\af1\\dbch\\af31505\\loch\\f1 \\tab }{\\rtlch\\fcs1 \\af1\\afs20 \\ltrch\\fcs0 \n"
+ "\\f1\\fs20\\insrsid13305240 \\hich\\af1\\dbch\\af31505\\loch\\f1 467.364 mm (18.4 inches)\n"
+ "\\par }{\\rtlch\\fcs1 \\ab\\af1\\afs20 \\ltrch\\fcs0 \\b\\f1\\fs20\\insrsid13305240\\charrsid3175333 \\hich\\af1\\dbch\\af31505\\loch\\f1 Rotation axis / Xray-source distance:}{\\rtlch\\fcs1 \\ab\\af1\\afs20 \\ltrch\\fcs0 \\b\\f1\\fs20\\uld\\insrsid13305240\\charrsid3175333 \n"
+ "\\hich\\af1\\dbch\\af31505\\loch\\f1 \\tab }{\\rtlch\\fcs1 \\ab\\af1\\afs20 \\ltrch\\fcs0 \\b\\f1\\fs20\\insrsid13305240\\charrsid3175333 \\hich\\af1\\dbch\\af31505\\loch\\f1 62.5 mm}{\\rtlch\\fcs1 \\af1\\afs20 \\ltrch\\fcs0 \\f1\\fs20\\insrsid13305240 \\hich\\af1\\dbch\\af31505\\loch\\f1\n"
+ "\\par \\tab \\hich\\af1\\dbch\\af31505\\loch\\f1 type:}{\\rtlch\\fcs1 \\af1\\afs20 \\ltrch\\fcs0 \\f1\\fs20\\uld\\insrsid3017018 \\tab \\tab \\tab }{\\rtlch\\fcs1 \\af1\\afs20 \\ltrch\\fcs0 \\f1\\fs20\\insrsid3017018 \\hich\\af1\\dbch\\af31505\\loch\\f1 step\n"
+ "\\par \\tab }{\\rtlch\\fcs1 \\ab\\af1\\afs20 \\ltrch\\fcs0 \\b\\f1\\fs20\\insrsid3017018\\charrsid7233753 \\hich\\af1\\dbch\\af31505\\loch\\f1 # projections:}{\\rtlch\\fcs1 \\ab\\af1\\afs20 \\ltrch\\fcs0 \\b\\f1\\fs20\\uld\\insrsid3017018\\charrsid7233753 \\tab \\tab }{\\rtlch\\fcs1 \n"
+ "\\ab\\af1\\afs20 \\ltrch\\fcs0 \\b\\f1\\fs20\\insrsid3017018\\charrsid7233753 \\hich\\af1\\dbch\\af31505\\loch\\f1 1440\n"
+ "\\par }{\\rtlch\\fcs1 \\af1\\afs20 \\ltrch\\fcs0 \\f1\\fs20\\insrsid3017018 \\tab \\hich\\af1\\dbch\\af31505\\loch\\f1 # frames averaged:}{\\rtlch\\fcs1 \\af1\\afs20 \\ltrch\\fcs0 \\f1\\fs20\\uld\\insrsid3017018 \\tab }{\\rtlch\\fcs1 \\af1\\afs20 \\ltrch\\fcs0 \\f1\\fs20\\insrsid3017018";
final String subst = "!!!!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}