const regex = new RegExp('!!mstart!!([\\S\\s]*?)!!mend!!', '')
const str = `!!mstart!!
<tr style='mso-yfti-irow:6'>
<td class="hidden" width="100%" colspan=6 valign=top style='width:100.0%;border:solid windowtext 1.0pt;
border-top:none;mso-border-top-alt:solid windowtext .5pt;mso-border-alt:solid windowtext .5pt;
background:#FBE4D5;mso-background-themecolor:accent2;mso-background-themetint:
51;padding:.1in 0in 0in 0in'>
<p class=MsoNormal style='margin-bottom:12.0pt;tab-stops:162.75pt'><span
style='font-size:18.0pt;font-family:"Calibri Light",sans-serif;mso-ascii-theme-font:
major-latin;mso-hansi-theme-font:major-latin;mso-bidi-theme-font:major-latin;
color:black;mso-color-alt:windowtext'><span style='mso-spacerun:yes'>
</span>Mailing Projects</span><span style='font-size:18.0pt;font-family:"Calibri Light",sans-serif;
mso-ascii-theme-font:major-latin;mso-hansi-theme-font:major-latin;mso-bidi-theme-font:
major-latin'><o:p></o:p></span></p>
<table class=MsoTableGrid border=1 cellspacing=0 cellpadding=0 width="100%"
style='border-collapse:collapse;mso-table-layout-alt:fixed;border:none;
mso-border-alt:solid windowtext .5pt;mso-yfti-tbllook:1184;mso-padding-alt:
.1in .1in .1in .1in'>
<tr style='mso-yfti-irow:0;mso-yfti-firstrow:yes'>
<td width=227 colspan=2 valign=top style='width:169.9pt;border-top:solid windowtext 1.0pt;
border-left:none;border-bottom:none;border-right:solid windowtext 1.0pt;
mso-border-top-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Postal Service:<o:p></o:p></p>
</td>
<td width=123 valign=top style='width:92.6pt;border-top:solid windowtext 1.0pt;
border-left:none;border-bottom:none;border-right:solid windowtext 1.0pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Postage Paid by:<o:p></o:p></p>
</td>
<td width=345 colspan=2 valign=top style='width:258.8pt;border-top:solid windowtext 1.0pt;
border-left:none;border-bottom:none;border-right:solid windowtext 1.0pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Package Components:<o:p></o:p></p>
</td>
<td width=345 colspan=3 valign=top style='width:258.85pt;border:none;
border-top:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Package Dimensions (inches):<o:p></o:p></p>
</td>
</tr>
<tr style='mso-yfti-irow:1'>
<td width=227 colspan=2 valign=top style='width:169.9pt;border-top:none;
border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;
mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<ul style='margin-top:0in' type=disc>
<li class=MsoListParagraph style='margin-left:0in;mso-list:l1 level1 lfo2'>\$PostalService\$<o:p></o:p></li>
</ul>
</td>
<td width=123 valign=top style='width:92.6pt;border-top:none;border-left:
none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
\$PostagePaidBy\$
</td>
<td width=345 colspan=2 valign=top style='width:258.8pt;border-top:none;
border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>\$PackageComponents\$<o:p></o:p></p>
</td>
<td width=345 colspan=3 valign=top style='width:258.85pt;border:none;
border-bottom:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-bottom-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>\$PackageDimensions\$<o:p></o:p></p>
</td>
</tr>
<tr style='mso-yfti-irow:2'>
<td width=1040 colspan=8 valign=top style='width:780.15pt;border:none;
border-bottom:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-top-alt:solid windowtext .5pt;mso-border-bottom-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal><b><span style='font-size:14.0pt;font-family:"Calibri Light",sans-serif;
mso-ascii-theme-font:major-latin;mso-hansi-theme-font:major-latin;
mso-bidi-theme-font:major-latin'>Package Detail<o:p></o:p></span></b></p>
</td>
</tr>
<tr style='mso-yfti-irow:3'>
<td width=173 valign=top style='width:129.45pt;border:none;border-right:
solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-top-alt:
solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Package 1<o:p></o:p></p>
</td>
<td width=177 colspan=2 valign=top style='width:133.05pt;border:none;
border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Package 2<o:p></o:p></p>
</td>
<td width=173 valign=top style='width:129.4pt;border:none;border-right:
solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:
solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:
solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Package 3<o:p></o:p></p>
</td>
<td width=173 valign=top style='width:129.4pt;border:none;border-right:
solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:
solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:
solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Package 4<o:p></o:p></p>
</td>
<td width=173 colspan=2 valign=top style='width:129.4pt;border:none;
border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Package 5<o:p></o:p></p>
</td>
<td width=173 valign=top style='width:129.45pt;border:none;mso-border-top-alt:
solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;padding:
.1in .1in .1in .1in'>
<p class=MsoNormal>Package 6<o:p></o:p></p>
</td>
</tr>
<tr style='mso-yfti-irow:4'>
<td width=173 valign=top style='width:129.45pt;border-top:none;border-left:
none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;
mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<ul style='margin-top:0in' type=disc>
\$Package1\$
</ul>
</td>
<td width=177 colspan=2 valign=top style='width:133.05pt;border-top:none;
border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<ul style='margin-top:0in' type=disc>
\$Package2\$
</ul>
</td>
<td width=173 valign=top style='width:129.4pt;border-top:none;border-left:
none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<ul style='margin-top:0in' type=disc>
\$Package3\$
</ul>
</td>
<td width=173 valign=top style='width:129.4pt;border-top:none;border-left:
none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<ul style='margin-top:0in' type=disc>
\$Package4\$
</ul>
</td>
<td width=173 colspan=2 valign=top style='width:129.4pt;border-top:none;
border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<ul style='margin-top:0in' type=disc>
\$Package5\$
</ul>
</td>
<td width=173 valign=top style='width:129.45pt;border:none;border-bottom:
solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-bottom-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<ul style='margin-top:0in' type=disc>
\$Package6\$
</ul>
</td>
</tr>
<tr style='mso-yfti-irow:5'>
<td width=173 valign=top style='width:129.45pt;border:none;border-right:
solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-top-alt:
solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Package Weight <span style='font-size:8.0pt'>(estimated)</span>:<o:p></o:p></p>
</td>
<td width=177 colspan=2 valign=top style='width:133.05pt;border:none;
border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Data Work Required:<o:p></o:p></p>
</td>
<td width=173 valign=top style='width:129.4pt;border:none;border-right:
solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:
solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:
solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Operations Required:<o:p></o:p></p>
</td>
<td width=259 colspan=2 valign=top style='width:194.1pt;border:none;
border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Mailing Instructions:<o:p></o:p></p>
</td>
<td width=259 colspan=2 valign=top style='width:194.15pt;border:none;
mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>Additional Comments:<o:p></o:p></p>
</td>
</tr>
<tr style='mso-yfti-irow:6;mso-yfti-lastrow:yes'>
<td width=173 valign=top style='width:129.45pt;border:none;border-right:
solid windowtext 1.0pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>\$WeightOfPackage\$<o:p></o:p></p>
</td>
<td width=177 colspan=2 valign=top style='width:133.05pt;border:none;
border-right:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
\$RequiredDataWork\$
</td>
<td width=173 valign=top style='width:129.4pt;border:none;border-right:
solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>\$OperationsRequired\$<o:p></o:p></p>
</td>
<td width=259 colspan=2 valign=top style='width:194.1pt;border:none;
border-right:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;
mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;
padding:.1in .1in .1in .1in'>
<p class=MsoNormal>\$SpecialMailingInstructions\$<o:p></o:p></p>
</td>
<td width=259 colspan=2 valign=top style='width:194.15pt;border:none;
mso-border-left-alt:solid windowtext .5pt;padding:.1in .1in .1in .1in'>
<p class=MsoNormal>\$MailAdditionalComments\$<o:p></o:p></p>
</td>
</tr>
<![if !supportMisalignedColumns]>
<tr height=0>
<td width=162 style='border:none'></td>
<td width=32 style='border:none'></td>
<td width=123 style='border:none'></td>
<td width=159 style='border:none'></td>
<td width=146 style='border:none'></td>
<td width=86 style='border:none'></td>
<td width=60 style='border:none'></td>
<td width=151 style='border:none'></td>
</tr>
<![endif]>
</table>
<p class=MsoNormal><o:p></o:p></p>
</td>
</tr>
!!mend!!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}