import re
regex = re.compile(r"!!mstart!!([\S\s]*?)!!mend!!")
test_str = ("!!mstart!!\n"
" <tr style='mso-yfti-irow:6'>\n"
" <td class=\"hidden\" width=\"100%\" colspan=6 valign=top style='width:100.0%;border:solid windowtext 1.0pt;\n"
" border-top:none;mso-border-top-alt:solid windowtext .5pt;mso-border-alt:solid windowtext .5pt;\n"
" background:#FBE4D5;mso-background-themecolor:accent2;mso-background-themetint:\n"
" 51;padding:.1in 0in 0in 0in'>\n"
" <p class=MsoNormal style='margin-bottom:12.0pt;tab-stops:162.75pt'><span\n"
" style='font-size:18.0pt;font-family:\"Calibri Light\",sans-serif;mso-ascii-theme-font:\n"
" major-latin;mso-hansi-theme-font:major-latin;mso-bidi-theme-font:major-latin;\n"
" color:black;mso-color-alt:windowtext'><span style='mso-spacerun:yes'>\n"
" </span>Mailing Projects</span><span style='font-size:18.0pt;font-family:\"Calibri Light\",sans-serif;\n"
" mso-ascii-theme-font:major-latin;mso-hansi-theme-font:major-latin;mso-bidi-theme-font:\n"
" major-latin'><o:p></o:p></span></p>\n"
" <table class=MsoTableGrid border=1 cellspacing=0 cellpadding=0 width=\"100%\"\n"
" style='border-collapse:collapse;mso-table-layout-alt:fixed;border:none;\n"
" mso-border-alt:solid windowtext .5pt;mso-yfti-tbllook:1184;mso-padding-alt:\n"
" .1in .1in .1in .1in'>\n"
" <tr style='mso-yfti-irow:0;mso-yfti-firstrow:yes'>\n"
" <td width=227 colspan=2 valign=top style='width:169.9pt;border-top:solid windowtext 1.0pt;\n"
" border-left:none;border-bottom:none;border-right:solid windowtext 1.0pt;\n"
" mso-border-top-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Postal Service:<o:p></o:p></p>\n"
" </td>\n"
" <td width=123 valign=top style='width:92.6pt;border-top:solid windowtext 1.0pt;\n"
" border-left:none;border-bottom:none;border-right:solid windowtext 1.0pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Postage Paid by:<o:p></o:p></p>\n"
" </td>\n"
" <td width=345 colspan=2 valign=top style='width:258.8pt;border-top:solid windowtext 1.0pt;\n"
" border-left:none;border-bottom:none;border-right:solid windowtext 1.0pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Package Components:<o:p></o:p></p>\n"
" </td>\n"
" <td width=345 colspan=3 valign=top style='width:258.85pt;border:none;\n"
" border-top:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Package Dimensions (inches):<o:p></o:p></p>\n"
" </td>\n"
" </tr>\n"
" <tr style='mso-yfti-irow:1'>\n"
" <td width=227 colspan=2 valign=top style='width:169.9pt;border-top:none;\n"
" border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;\n"
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <ul style='margin-top:0in' type=disc>\n"
" <li class=MsoListParagraph style='margin-left:0in;mso-list:l1 level1 lfo2'>$PostalService$<o:p></o:p></li>\n"
" </ul>\n"
" </td>\n"
" <td width=123 valign=top style='width:92.6pt;border-top:none;border-left:\n"
" none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" $PostagePaidBy$\n"
" </td>\n"
" <td width=345 colspan=2 valign=top style='width:258.8pt;border-top:none;\n"
" border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>$PackageComponents$<o:p></o:p></p>\n"
" </td>\n"
" <td width=345 colspan=3 valign=top style='width:258.85pt;border:none;\n"
" border-bottom:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-bottom-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>$PackageDimensions$<o:p></o:p></p>\n"
" </td>\n"
" </tr>\n"
" <tr style='mso-yfti-irow:2'>\n"
" <td width=1040 colspan=8 valign=top style='width:780.15pt;border:none;\n"
" border-bottom:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-top-alt:solid windowtext .5pt;mso-border-bottom-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal><b><span style='font-size:14.0pt;font-family:\"Calibri Light\",sans-serif;\n"
" mso-ascii-theme-font:major-latin;mso-hansi-theme-font:major-latin;\n"
" mso-bidi-theme-font:major-latin'>Package Detail<o:p></o:p></span></b></p>\n"
" </td>\n"
" </tr>\n"
" <tr style='mso-yfti-irow:3'>\n"
" <td width=173 valign=top style='width:129.45pt;border:none;border-right:\n"
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-top-alt:\n"
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Package 1<o:p></o:p></p>\n"
" </td>\n"
" <td width=177 colspan=2 valign=top style='width:133.05pt;border:none;\n"
" border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Package 2<o:p></o:p></p>\n"
" </td>\n"
" <td width=173 valign=top style='width:129.4pt;border:none;border-right:\n"
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:\n"
" solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:\n"
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Package 3<o:p></o:p></p>\n"
" </td>\n"
" <td width=173 valign=top style='width:129.4pt;border:none;border-right:\n"
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:\n"
" solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:\n"
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Package 4<o:p></o:p></p>\n"
" </td>\n"
" <td width=173 colspan=2 valign=top style='width:129.4pt;border:none;\n"
" border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Package 5<o:p></o:p></p>\n"
" </td>\n"
" <td width=173 valign=top style='width:129.45pt;border:none;mso-border-top-alt:\n"
" solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;padding:\n"
" .1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Package 6<o:p></o:p></p>\n"
" </td>\n"
" </tr>\n"
" <tr style='mso-yfti-irow:4'>\n"
" <td width=173 valign=top style='width:129.45pt;border-top:none;border-left:\n"
" none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;\n"
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <ul style='margin-top:0in' type=disc>\n"
" $Package1$\n"
" </ul>\n"
" </td>\n"
" <td width=177 colspan=2 valign=top style='width:133.05pt;border-top:none;\n"
" border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <ul style='margin-top:0in' type=disc>\n"
" $Package2$\n"
" </ul>\n"
" </td>\n"
" <td width=173 valign=top style='width:129.4pt;border-top:none;border-left:\n"
" none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <ul style='margin-top:0in' type=disc>\n"
" $Package3$\n"
" </ul>\n"
" </td>\n"
" <td width=173 valign=top style='width:129.4pt;border-top:none;border-left:\n"
" none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <ul style='margin-top:0in' type=disc>\n"
" $Package4$\n"
" </ul>\n"
" </td>\n"
" <td width=173 colspan=2 valign=top style='width:129.4pt;border-top:none;\n"
" border-left:none;border-bottom:solid windowtext 1.0pt;border-right:solid windowtext 1.0pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-bottom-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <ul style='margin-top:0in' type=disc>\n"
" $Package5$\n"
" </ul>\n"
" </td>\n"
" <td width=173 valign=top style='width:129.45pt;border:none;border-bottom:\n"
" solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-bottom-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <ul style='margin-top:0in' type=disc>\n"
" $Package6$\n"
" </ul>\n"
" </td>\n"
" </tr>\n"
" <tr style='mso-yfti-irow:5'>\n"
" <td width=173 valign=top style='width:129.45pt;border:none;border-right:\n"
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-top-alt:\n"
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Package Weight <span style='font-size:8.0pt'>(estimated)</span>:<o:p></o:p></p>\n"
" </td>\n"
" <td width=177 colspan=2 valign=top style='width:133.05pt;border:none;\n"
" border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Data Work Required:<o:p></o:p></p>\n"
" </td>\n"
" <td width=173 valign=top style='width:129.4pt;border:none;border-right:\n"
" solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:\n"
" solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:\n"
" solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Operations Required:<o:p></o:p></p>\n"
" </td>\n"
" <td width=259 colspan=2 valign=top style='width:194.1pt;border:none;\n"
" border-right:solid windowtext 1.0pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-top-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Mailing Instructions:<o:p></o:p></p>\n"
" </td>\n"
" <td width=259 colspan=2 valign=top style='width:194.15pt;border:none;\n"
" mso-border-top-alt:solid windowtext .5pt;mso-border-left-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>Additional Comments:<o:p></o:p></p>\n"
" </td>\n"
" </tr>\n"
" <tr style='mso-yfti-irow:6;mso-yfti-lastrow:yes'>\n"
" <td width=173 valign=top style='width:129.45pt;border:none;border-right:\n"
" solid windowtext 1.0pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>$WeightOfPackage$<o:p></o:p></p>\n"
" </td>\n"
" <td width=177 colspan=2 valign=top style='width:133.05pt;border:none;\n"
" border-right:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" $RequiredDataWork$\n"
" </td>\n"
" <td width=173 valign=top style='width:129.4pt;border:none;border-right:\n"
" solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>$OperationsRequired$<o:p></o:p></p>\n"
" </td>\n"
" <td width=259 colspan=2 valign=top style='width:194.1pt;border:none;\n"
" border-right:solid windowtext 1.0pt;mso-border-left-alt:solid windowtext .5pt;\n"
" mso-border-left-alt:solid windowtext .5pt;mso-border-right-alt:solid windowtext .5pt;\n"
" padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>$SpecialMailingInstructions$<o:p></o:p></p>\n"
" </td>\n"
" <td width=259 colspan=2 valign=top style='width:194.15pt;border:none;\n"
" mso-border-left-alt:solid windowtext .5pt;padding:.1in .1in .1in .1in'>\n"
" <p class=MsoNormal>$MailAdditionalComments$<o:p></o:p></p>\n"
" </td>\n"
" </tr>\n"
" <![if !supportMisalignedColumns]>\n"
" <tr height=0>\n"
" <td width=162 style='border:none'></td>\n"
" <td width=32 style='border:none'></td>\n"
" <td width=123 style='border:none'></td>\n"
" <td width=159 style='border:none'></td>\n"
" <td width=146 style='border:none'></td>\n"
" <td width=86 style='border:none'></td>\n"
" <td width=60 style='border:none'></td>\n"
" <td width=151 style='border:none'></td>\n"
" </tr>\n"
" <![endif]>\n"
" </table>\n"
" <p class=MsoNormal><o:p></o:p></p>\n"
" </td>\n"
" </tr>\n"
"!!mend!!\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")