$re = '/(?:class="|\G(?!^))\s*\K[^\s"]+/';
$str = '<div class="main menu">element</div>
<div class="content"></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);