$re = '/^\d+,?\d{0,2}$/m';
$str = '1
12
12,
12,3
12,34
12,456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);