using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!content="")(?<!content=""https:)(?<!content=""http:)((https?:)?(//website.com))";
string input = @"<meta content=""https://website.com"">
href =""https://website.com""
https://website.com
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}