const regex = new RegExp('(?<!content=")(?<!content="https:)(?<!content="http:)((https?:)?(//website.com))', 'g')
const str = `<meta content="https://website.com">
href ="https://website.com"
https://website.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}