package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^][=]*color(?:=[^][=]+)?]`)
var str = `[valign px=-2][center][bgcolor=GREEN]TESTING[/bgcolor][/center][/valign]
color=GREEN] AND color] ---> Target ---> [bgcolor=GREEN] AND [/bgcolor]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}