re = /\[[^][=]*color(?:=[^][=]+)?]/m
str = '[valign px=-2][center][bgcolor=GREEN]TESTING[/bgcolor][/center][/valign]
color=GREEN] AND color] ---> Target ---> [bgcolor=GREEN] AND [/bgcolor]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end