import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<name>post|get|url)\\:(?P<data>(?:.(?!(et\\:)|(ost\\:)|(rl\\:)))+)";
final String string = "dfkjsfkj dskljsdlfm sdfkjdsf sfsd get\n\n"
+ "asdkljasd,laosid post: \n"
+ "в\n"
+ "get:787wesdjdddddddddddddd hfsdfnxczp\n\n"
+ "url: oiwerweroi;get:787wesdjhfsdfnxczp";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}