re = /^[0-9]{2}([A-Z]{3}[P,C,H,A,B,G,J,L,F,T][A-Z][0-9]{4}[A-Z])[0-9][Z][0-9]$/
str = '15CKTPB7841R5Z5'
# Print the match result
str.match(re) do |match|
puts match.to_s
end