import Foundation
let pattern = #"^[0-9]{2}([A-Z]{3}[P,C,H,A,B,G,J,L,F,T][A-Z][0-9]{4}[A-Z])[0-9][Z][0-9]$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"15CKTPB7841R5Z5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}