package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([0-9]|10)|([0-9][.,][0]?[1-9][1-9]?))$`)
var str = `0
5
10
0.5
0.25
5.75
3.03
5.0
3.333
11
20
05
10.5
3.30
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}