import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([0-9]|10)|([0-9][.,][0]?[1-9][1-9]?))$";
final String string = "0\n"
+ "5\n"
+ "10\n"
+ "0.5\n"
+ "0.25\n"
+ "5.75\n"
+ "3.03\n\n"
+ "5.0\n"
+ "3.333\n"
+ "11\n"
+ "20\n"
+ "05\n"
+ "10.5\n"
+ "3.30\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}