re = /HELLO: ([^|]+)/
str = 'THIS IS MY EXAMPLE|OTHER EXAMPLE|HELLO: Kevin|OTHER EXAMPLE|OTHER EXAMPLE'
# Print the match result
str.match(re) do |match|
puts match.to_s
end