package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(1I)|(I1)|([Ii][Ll])|([Ll][Ii])`)
var str = `linux`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}