$re = '/(1I)|(I1)|([Ii][Ll])|([Ll][Ii])/';
$str = 'linux';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);