using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(1.*I)|(I.*1)|([Ii].*[Ll])|([Ll].*[Ii])";
string input = @"1fdsafsI ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}