package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(1.*I)|(I.*1)|([Ii].*[Ll])|([Ll].*[Ii])`)
var str = `1fdsafsI `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}