#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?(\w)\1.*?$"
Local $sString = "following should return false :" & @CRLF & _
"abc1" & @CRLF & _
"abc" & @CRLF & _
"" & @CRLF & _
"following should return true :" & @CRLF & _
"abc11" & @CRLF & _
"1abc1" & @CRLF & _
"aabc1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")