const regex = /^.*?(\w)\1.*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(\\w)\\1.*?$', 'gm')
const str = `following should return false :
abc1
abc
following should return true :
abc11
1abc1
aabc1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}