using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(href=""([^""]*))?(?:(?!href="")[^>])*>(.*)";
string input = @"<a href=""world.html"">Hello
<b>Hello";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}