re = /(href="([^"]*))?(?:(?!href=")[^>])*>(.*)/
str = '<a href="world.html">Hello
<b>Hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end