package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_([^_]+)$`)
var str = `sample_a
sample_a
sample_b
sample_c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}