$re = '/_([^_]+)$/m';
$str = 'sample_a
sample_a
sample_b
sample_c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);