package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\d{1,2}/\d{1,2}/\d{1,2}, \d{1,2}:\d{1,2}:\d{1,2} [AP]M\]`)
var str = `something something [10/6/17, 11:13:52 AM] something
something something [1/10/17, 11:13:52 PM] something`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}