$re = '/\[\d{1,2}/\d{1,2}/\d{1,2}, \d{1,2}:\d{1,2}:\d{1,2} [AP]M\]/';
$str = 'something something [10/6/17, 11:13:52 AM] something
something something [1/10/17, 11:13:52 PM] something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);