// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(<script[^>]*src=[\'\"](.*?)[\'\"].*?\>(<\/script>)?)"#).unwrap();
let string = "<script type=\"text/javascript\" src=\"https://www.google.com/jsapi1\"></script><script type=\"text/javascript\" src=\"https://www.google.com/jsapi4\"></script><script type=\"text/javascript\" src=\"https://www.google.com/jsapi3\"/><script type=\"text/javascript\" src=\"https://www.google.com/jsapi2\"></script><script type=\"text/javascript\" src=\"https://www.google.com/jsapi31\"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}