import Foundation
let pattern = #"(<script[^>]*src=[\'\"](.*?)[\'\"].*?\>(<\/script>)?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<script type="text/javascript" src="https://www.google.com/jsapi1"></script><script type="text/javascript" src="https://www.google.com/jsapi4"></script><script type="text/javascript" src="https://www.google.com/jsapi3"/><script type="text/javascript" src="https://www.google.com/jsapi2"></script><script type="text/javascript" src="https://www.google.com/jsapi31"/>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)