$re = '/\{[^|}]++\|([^|}]++)(?:\|[^|}]++)*\}/';
$str = '{Feel free to|Twenty-four hours a day|Do|Then|You can} stop on by, or {contact us|e mail us|call us|e-mail us|email us} about {your needs|your requirements|your preferences|the needs you have|your family needs}. {We look forward|Good quality} to {hearing from|talking with|listening to|meeting up with} you!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);