const regex = /(?<!\d)((0)?[1-9]|[12][0-9]|3[01])(?(2)\D?|\D)(0?[1-9]|1[0-2])(?(2)\D?|\D)([12][0-9]|20[12][0-9])(?!\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)((0)?[1-9]|[12][0-9]|3[01])(?(2)\\D?|\\D)(0?[1-9]|1[0-2])(?(2)\\D?|\\D)([12][0-9]|20[12][0-9])(?!\\d)', 'g')
const str = `01-05-2015
01-05-15
01052015
010515
1-5-2015
152015`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}