re = /(?<!\d)((0)?[1-9]|[12][0-9]|3[01])(?(2)\D?|\D)(0?[1-9]|1[0-2])(?(2)\D?|\D)([12][0-9]|20[12][0-9])(?!\d)/
str = '01-05-2015
01-05-15
01052015
010515
1-5-2015
152015'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end