using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^figurines-([-a-z0-9]+).html$";
string input = @"figurines-foo42.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}