$re = '/^figurines-([-a-z0-9]+).html$/m';
$str = 'figurines-foo42.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);