import re
regex = re.compile(r"node\/([1-9]{1,10})\/", flags=re.MULTILINE)
test_str = ("<a href=\"/node/134358/publicar?destination=admin/dashboard/notas\">No publicado</a>\n\n"
"<a href=\"/node/134358/publicar?destination=admin/dashboard/notas\">Publicado</a>\n\n"
"<a href=\"/node/1/publicar?destination=admin/dashboard/notas\">Publicado</a>\n\n"
"<a href=\"/node/1234567/publicar?destination=admin/dashboard/notas\">Publicado</a>\n\n"
"<a href=\"/node/123456789/publicar?destination=admin/dashboard/notas\">Publicado</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")