#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)((([A-Za-z]{3,9}:(?:\/\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+(:[0-9]+)?|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)"
Local $sString = "ftp://eau.ww.eesd.gov.calgary/home/smith/budget.wk1" & @CRLF & _
"" & @CRLF & _
"gopher://gopher.voa.gov" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.apple.com/index.html" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.cuug.ab.ca:8001/~branderr/csce.html"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)