package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)((([A-Za-z]{3,9}:(?:\/\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+(:[0-9]+)?|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)`)
var str = `ftp://eau.ww.eesd.gov.calgary/home/smith/budget.wk1
gopher://gopher.voa.gov
http://www.apple.com/index.html
https://www.cuug.ab.ca:8001/~branderr/csce.html`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}