$re = '/.*\/(\d+)/';
$str = '_uploads/_documents/1254_test_doc1.pdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);